ShopWind开源电商系统用composer升级Yii问题解决

admin 发布于 二次开发 2021-12-24 20:16:19

ShopWind基于优秀的开源框架Yii2.0底层开发,采用MVC开发模式,逻辑层和视图层完美分离,拓展性高,安全性高。Yii以快速、安全、专业著称,是一个高性能、高拓展,适合开发大型WEB2.0的PHP框架。
ShopWind电商系统V3.x 已经对Yii底层做了比较深入的二次开发,如果用composer对Yii框架进行升级,升级成功后会把ShopWind做二开修改到的一些文件覆盖掉,致使在使用过程中,调用到相应的模块或组件的时候会出现一定的错误提示。如以下重点的文件做了修改或新增,在ShopWind项目中不可或缺。如果用composer对项目做升级,需要重新使用到以下文件:

vendor\mk-j\php_xlsxwriter\xlsxwriter.class.php
vendor\smarty\smarty\libs\plugins\function.lib.php
vendor\smarty\smarty\libs\plugins\function.res.php
vendor\smarty\smarty\libs\plugins\function.widgets.php
vendor\smarty\smarty\libs\plugins\modifier.date_format.php
vendor\smarty\smarty\libs\plugins\modifier.price_format.php
vendor\smarty\smarty\libs\plugins\modifier.url_format.php
最后编辑于 2022-01-04 21:25:28
0 716
Re :

admin 这家伙什么都没留下

  • 回答

    97
  • 发布

    86
  • 经验

    6430

内容精选

联系我们

  • 微信官网

    关注公众号

    系统更新,推送提醒
  • 开发交流群

    技术交流Q群

    安装使用,开发交流

垂询热线:18978189162